SharePoint 2010 と .Net Framework 4.0

by manamana 8. March 2013 08:00

Excel PowerShell Tool は .Net Framework 4.0 を採用しています。

SharePoint 2010 用のスクリプトを組んで検証しようとした所、次のようなエラーに会いました。

どうやら SP2010 のコマンドレットは .Net Framework 4.0 環境と相性が悪いようです。
そういえば、PowerShell 3.0 (≒WinMF 3.0) を導入すると SP2010 の管理ができなくなるという話がありました…
これは PowerShell の呼び出しに -version 2 オプションを付けることで回避できる様ですが、
PS Tool にはそのようなオプションはありません…

SharePoint 2013 なら問題ないハズですが、こちらはまだ未経験。なにせリソース食い過ぎで入れる環境がない...orz
SP2010 を無視するわけにはいかないので、対応が必要となりそうです。 

Tags:

Add comment


スポンサーリンク

Calendar

<<  April 2021  >>
SunMonTueWedThuFriSat
28293031123
45678910
11121314151617
18192021222324
2526272829301
2345678

View posts in large calendar

Month List

Twitter